Knowledge Base

ionCube Loader setup

If you use AliDropship hosting you don’t need to install ionCube loader because it is installed and enabled by default.

Nowadays ionСube loader is supported or installed almost by all hosting providers.  The easy way to know this is to contact your hosting support.

To make AliDropship plugin work properly you need PHP ver. 5.6 (or higher).

How to know about your hosting system and environment from PHP Info?

 

  • Type http://yourdomain.com/phpinfo.php
  • If phpinfo.php not exist, create one and add the following code to it:

<?php

phpinfo();

?>

  • Save the file as phpinfo.php and upload to the root.
  • Now http://yourdomain.com/phpinfo.php can give you the required details as in this screenshot
  • First ensure that ionCube loader is enabled already.

The highlighted output explained:

  1. The first Header line describes you the php version
  2. Next – ‘System’ describes the system processor type e.g. x86-64. This is needed to download appropriate loaders.
  3. You can find information that ioncube loader is enabled at the bottom of the page.

So, your steps are:

  • Search for ionCube, if you can’t find anything similar, then it is not enabled.
  • Search the hosting FAQ, forum for any instruction to enable ionCube.
  • The quickest solution will be contacting your hosting support. It will take seconds for them to enable it.

Installing ioncube in Top Hosting Providers:

 

  1. GoDaddy: 

Go to cPanel -> Software -> Select PHP version

Select PHP version, not older than 5.6, tick on ioncube_loader and click ‘Save’.

2. Hostgator: Click here!

3. Blue Host: Click here!

4. Hostmonster: Click here!

5. Dreamhost: Click here!

Did you find this article helpful?
35% of people found this helpful
Contact Us

Have any questions or need to get more information about the product? Either way, you’re in the right spot.

 +1 323-7395659
 AliDropship